Recent Posts

You have held broken packages 16 04

By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up. I am using Ubuntu I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it.

Digi plan 2019

Then something broke. After that, you should be able to remove the conflicting package it seems to be npm and then reinstall all. If this fail, you can try the aptitude way often it's able to disentangle dependency trees better. In both cases, be careful when applying commands, and check carefully the list of packages that are marked for remove. Use aptitude instead of apt-get.

It is more intelligent. It not only will handle downgrading conflicting packages for you, but will make a series of recommendations asking you which of many possible suggested working scenarios you would like. For me to solve this problem, I just had to install synaptic first using below commmand, and then everything works fine.

I found out that dpkg -r allows me to remove packages one-by-one, without triggering a cascade of other behaviour. Ubuntu Community Ask! Sign up to join this community. The best answers are voted up and rise to the top.

E: Unable to correct problems, you have held broken packages Ask Question. Asked 6 years, 11 months ago. Active 3 years, 2 months ago. Viewed k times. Done Building dependency tree Reading state information Done Some packages could not be installed.

This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation: The following packages have unmet dependencies: nodejs : Conflicts: npm E: Unable to correct problems, you have held broken packages.

Please satisfy yourself as to your rights to use the software.

you have held broken packages 16 04

This software is not part of Ubuntu, but is offered by Canonical and the respective vendors as a service to Ubuntu users. John Qualis John Qualis 1, 2 2 gold badges 9 9 silver badges 4 4 bronze badges. Not sure whats the question however this can help you Go to synaptic package manager.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up.

I am attempting to install the latest development version of Wine wine-devel under Ubuntu How do I successfully complete the installation of Wine Development version under Ubuntu This error comes about because WineHQ wine-devel now requires the installation of an FAudio package for installation to succeed.

you have held broken packages 16 04

Fortunately this can be worked around fairly easily under Ubuntu You will need to add the 32bit architecture to your 64bit system as well as add the Wine PPA and key:. For Ubuntu Ubuntu Community Ask! Sign up to join this community.

The best answers are voted up and rise to the top. Error message while installing the development version of Wine: Ubuntu Asked 8 months ago.

Active 8 months ago. Viewed times. Active Oldest Votes. Add FAudio For Ubuntu Note that these packages will be updated from time to time, most recent update Jan 27th used in this answer. The Overflow Blog. Podcast Ben answers his first question on Stack Overflow.

The Overflow Bugs vs. Upcoming Events. Intro to command line continued in 7 days. Featured on Meta. Responding to the Lavender Letter and commitments moving forward. Scheduling lessons for 10th anniversary celebration classroom. Happy 10th anniversary to Ask Ubuntu! Linked Related 0. Hot Network Questions.

Ask Ubuntu works best with JavaScript enabled.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up. Ubuntu Community Ask! Sign up to join this community. The best answers are voted up and rise to the top. Unable to correct problems, you have held broken packagesWhen I Install php on ubuntu Asked 4 years, 1 month ago.

Active 3 years, 11 months ago. Viewed 20k times.

Chase app not recognizing mobile device

Why I see this problem when i want to install php on ubuntu Fabby Ghadeer R. Majeed Ghadeer R. Majeed 2 2 gold badges 2 2 silver badges 8 8 bronze badges. Majeed Aug 20 '16 at Active Oldest Votes.

How To Fix Problem You might Want To Run 'apt fix broken install' In Kali Linux 2019

You can use Aptitude to automatically fix the broken packages. Nick Weinberg 4, 4 4 gold badges 21 21 silver badges 29 29 bronze badges. Fcmam5 Fcmam5 2 2 silver badges 8 8 bronze badges. Thank you Mr Fabby, I'm a newbie here trying to help, thank you for your advice. Much better! There is also an edit button next to your comment, so you can edit it Also note there is a little grey cross next to you comment, so you can delete comments that you don't want to appear any more!!!

Sign up or log in Sign up using Google. Sign up using Facebook. Sign up using Email and Password. Post as a guest Name.

How To Fix Broken Packages In Ubuntu 18.04 LTS

Email Required, but never shown. The Overflow Blog. Podcast Ben answers his first question on Stack Overflow. The Overflow Bugs vs. Upcoming Events. Intro to command line continued in 7 days. Featured on Meta.

you have held broken packages 16 04

Responding to the Lavender Letter and commitments moving forward. Scheduling lessons for 10th anniversary celebration classroom.

Kuchindana ku malawi

Happy 10th anniversary to Ask Ubuntu! Linked Related 0.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up. Please note the version of php. Other Ref : php version issue. After that, install MariaDB server.

I got the same error, but it turned out to be because I had installed std mysql and had uninstalled it. Mariadb is available in official Ubuntu repositories so no need to enable third-party repositories. Most likely your installation has only main enabled.

You can enable universe with How do I enable the "Universe" repository? I am using Ubuntu The one solution above worked for me, although the were some error messages about old packages. Ubuntu Community Ask! Sign up to join this community. The best answers are voted up and rise to the top. Unable to install MariaDB on Asked 4 years, 5 months ago. Active 1 year ago. Viewed 48k times. Done Building dependency tree Reading state information Done Some packages could not be installed.

This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: mariadb-server : Depends: mariadb-server Anwar Amit Patel Amit Patel 1 1 gold badge 6 6 silver badges 11 11 bronze badges. Active Oldest Votes. Please check that Apache and php packages exist or not in your machine.

Ajay Barot Ajay Barot 1 1 gold badge 4 4 silver badges 16 16 bronze badges. In my case, the ibdata1 file was corrupt. John Barret 33 6 6 bronze badges. LinuxBabe LinuxBabe 2 2 silver badges 7 7 bronze badges.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Stack Overflow for Teams is a private, secure spot for you and your coworkers to find and share information. I have tried this suggested solution, however it did not work.

Learn more. Asked 2 years, 8 months ago. Active 10 months ago. Viewed 2k times. I am trying to install ROS Indigo. Done Building dependency tree Reading state information Done Some packages could not be installed.

This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-indigo-desktop-full : Depends: ros-indigo-desktop but it is not going to be installed Depends: ros-indigo-perception but it is not going to be installed Depends: ros-indigo-simulators but it is not going to be installed Depends: ros-indigo-urdf-tutorial but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Active Oldest Votes. Mohammad Ali Mohammad Ali 3 3 silver badges 10 10 bronze badges. Try using to handle the error: sudo get upgrade. Armel 2, 6 6 gold badges 15 15 silver badges 27 27 bronze badges. Samyak Gupta Samyak Gupta 21 3 3 bronze badges. Sign up or log in Sign up using Google.

Sign up using Facebook. Sign up using Email and Password. Post as a guest Name. Email Required, but never shown. The Overflow Blog. Podcast Ben answers his first question on Stack Overflow. The Overflow Bugs vs. Featured on Meta. Responding to the Lavender Letter and commitments moving forward.

Subscribe to RSS

Linked 0. Related 4. Hot Network Questions. Question feed. Stack Overflow works best with JavaScript enabled.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service. Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up.

How to take apart a bushnell rechargeable flashlight

After upgrading from For instance ialibs and skype 4. When trying to install these, I am getting the 'Unable to correct problems, you have held broken packages' error message.

That particular error message may indicate that you have held packages, but it may also indicate a different problem. If there are none, or none look related, then it's probably something else.

Check carefully the output of the command you were trying when you got the error message, as there may be other clues in the full output from that command, aside from the error message. Another method of troubleshooting may be to use aptitude rather than apt-get to try to install your package:.

you have held broken packages 16 04

Aptitude will give up less easily, and will attempt to find solutions which may involve modifying other packages. It may give you more explanation of the problem and options for fixing it.

That happened to me too. All I did was sudo apt-get update and that fixed my issue. Good luck. I had a similar scenario in a fresh install of Open your sources.

If you find any incorrect release lines in sources. Select the Fix Broken Packages option in Synaptic package manager. Run the following commands to install Synaptic. In Synaptic in the left pane click the Custom Filters button which is marked by the mouse cursor in the below screenshot. From the list in the top left corner select Broken.

In the center pane will be listed any broken packages that still need to be repaired. Select the broken packages one at a time. The results of this command will tell you if that broken package was installed from the default Ubuntu repositories or from some other source.By using our site, you acknowledge that you have read and understand our Cookie PolicyPrivacy Policyand our Terms of Service.

Ask Ubuntu is a question and answer site for Ubuntu users and developers. It only takes a minute to sign up. I ran sudo apt upgrade and several things were upgraded, but I still got the same error. The upgrade command refused to upgrade these three items: liblxc1, lxd, lxd-client not sure why. Ubuntu Community Ask! Sign up to join this community. The best answers are voted up and rise to the top.

Installing certbot on Ubuntu Asked 2 years, 2 months ago. Active 2 years, 2 months ago. Viewed 3k times. Done Building dependency tree Reading state information Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation: The following packages have unmet dependencies: python-certbot-nginx : Depends: python3-certbot-nginx but it is not going to be installed E: Unable to correct problems, you have held broken packages. Done Reading package lists Done Package gcc is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: gccdoc Package libffi-dev is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or is only available from another source Package python-virtualenv is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Package python-dev is not available, but is referred to by another package.

This may mean that the package is missing, has been obsoleted, or is only available from another source However the following packages replace it: python E: Package 'python-dev' has no installation candidate E: Package 'python-virtualenv' has no installation candidate E: Package 'gcc' has no installation candidate E: Package 'libffi-dev' has no installation candidate I'm not sure where to go from here.

Any idea why this is happening and how to resolve the issue? Jim Jim 2 2 silver badges 6 6 bronze badges. Active Oldest Votes. What I did to solve this problem on See if you have python not just python3 installed. If not: sudo apt install python Then you can add the python certbot.

Both Python 3 and Python 2 are installed. I can launch Python 3 via python3 which yields a Python 3. And running just python launches Python 2. Since python 2x is already installed you can go to the next step. Did the rest of the post help? Adding the universe repository and then installing python-certbot-nginx? Unfortunately I still get the exact same error "packages have unmet dependencies"even after adding universe and rerunning the apt-get install python-certbox-nginx.

Sign up or log in Sign up using Google. Sign up using Facebook. Sign up using Email and Password.




thoughts on “You have held broken packages 16 04”

Leave a Reply

Your email address will not be published. Required fields are marked *